Error installing the Application web catalog

Just ran into an error this morning while installing the Application Web Catalog role on my ConfigMgr 2012 server. When trying to log on to the catalog I got an IIS error related. I look into the SMSPortalWebSetup.log file on the site server and noticed this Error: IIS Asp.Net is not registered

image

To fix the error I had to manually registered the component

  1. Open a command prompt as administrator and navigate to C:\Windows\Microsoft.Net\Framework64\v4.0.30319\
  2. type aspnet_regiis –i and Enter

    image

  3. Remove the Application Web catalog role and reinstalled it (not needed but I didn’t want to wait for the reinstall process to kick in)
  4. Now my Application Catalog is installed correctly

    image

    image


Comments (2):

  1. GenerAHL says:

    I’ve seen this happening if you install .NET Framework 4 before you add the IIS-role. Because of this, I’ve added the aspnet_regiis.exe action to my installation-procedure just in-case…

  2. Morten says:

    What to do when you get the same error with 2012 server. if I try to run this command I get this message:

    This option is not supported on this version of the operating system. Administr
    ators should instead install/uninstall ASP.NET 4.5 with IIS8 using the “Turn Win
    dows Features On/Off” dialog, the Server Manager management tool, or the dism.e
    xe command line tool. For more details please see http://go.microsoft.com/fwlin
    k/?LinkID=216771.

    I cant untick the aspn.net 4.5 in the install/uninstall because its grayed out

Leave a Reply

CAPTCHA Image
(required)